Rails AsstNotPreconpiled in Postsってエラーは?

Rails

railsにjQueryを装備したらエラーが出たので修正しました。

エラー画面

下記がhtmlファイルに記載しただけなのでエラーの原因になりました。

<%= javascript_include_tag'jquery-3.3.1.min.js' %>
<%= javascript_include_tag'Sortable.js' %>

編集ファイルパス:config/initializers/assets.rb このファイルにRails.application.config.assets.precompile += %w( jquery-3.3.1.min.js )と Rails.application.config.assets.precompile += %w( Sortable.js ) を2行追加します。

編集ファイルパス:config/initializers/assets.rb このファイルにRails.application.config.assets.precompile += %w( jquery-3.3.1.min.js )と Rails.application.config.assets.precompile += %w( Sortable.js ) を2行追加します。

Rails5のエラーSprockets::Rails::Helper::AssetNotPrecompiled
Ruby on Rails5で新規のCoffeeScript名を追加した再にSprockets::Rails::Helper::AssetNotPrecompiled というエラーが発生したので、対応方法を記載します。
タイトルとURLをコピーしました